import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\/)[^\\/]*(?=\\.)";
final String string = "src/profile/Admin.profile\n"
+ "src/profile/Chatter External User.profile\n"
+ "src/profile/Chatter Free User.profile\n"
+ "src/profile/Chatter Moderator User.profile\n"
+ "src/profile/Company Communities User.profile\n"
+ "src/profile/ContractManager.profile\n"
+ "src/profile/Guest License User.profile\n"
+ "src/profile/High Volume Customer Portal User.profile\n"
+ "src/profile/Integratie.profile\n"
+ "src/profile/MarketingProfile.profile\n"
+ "src/profile/OWS.profile\n"
+ "src/profile/Photos Profile.profile\n"
+ "src/profile/PostNL - Audit.profile\n"
+ "src/profile/PostNL - Business gebruiker.profile\n"
+ "src/profile/PostNL - Controlroom C%26S Aanmaker - CC.profile\n"
+ "src/profile/PostNL - Controlroom C%26S Analist - CC.profile\n"
+ "src/profile/PostNL - Controlroom C%26S Behandelaar - CC.profile\n"
+ "src/profile/PostNL - DUB - CC.profile\n"
+ "src/profile/PostNL - Directeur V%26B - CC.profile\n"
+ "src/profile/PostNL - IT Servicedesk - CC.profile\n"
+ "src/profile/PostNL - K%26K behandelaar.profile\n"
+ "src/profile/PostNL - Klachten Behandelaar - CC.profile\n"
+ "src/profile/PostNL - Klachten Inzage - CC.profile\n"
+ "src/profile/PostNL - Netwerk Behandelaar.profile\n"
+ "src/profile/PostNL - OBSB - CC.profile\n"
+ "src/profile/PostNL - OBSB Beheerder - CC.profile\n"
+ "src/profile/PostNL - OR Administrator - CC.profile\n"
+ "src/profile/PostNL - Postbezorger Community - CC.profile\n"
+ "src/profile/PostNL - Postbezorger Community Chatter - CC.profile\n"
+ "src/profile/PostNL - Postbezorger Community Chauffeur - CC.profile\n"
+ "src/profile/PostNL - Postbezorger Community Extern - CC.profile\n"
+ "src/profile/PostNL - Postbezorger Community PB ZW - CC.profile\n"
+ "src/profile/PostNL - Postbezorger Community Voorbereiden - CC.profile\n"
+ "src/profile/PostNL - Procesmanager Bezorgen - CC.profile\n"
+ "src/profile/PostNL - Procesmanager Voorbereiden - CC.profile\n"
+ "src/profile/PostNL - Regiomanagers - CC.profile\n"
+ "src/profile/PostNL - Service Centrum Medewerker.profile\n"
+ "src/profile/PostNL - Teamleider - CC.profile\n"
+ "src/profile/PostNL - Teamleider Voorbereiden - CC.profile\n"
+ "src/profile/PostNL - Werkorder behandelaar - CC.profile\n"
+ "src/profile/ReadOnly.profile\n"
+ "src/profile/SolutionManager.profile\n"
+ "src/profile/Standard.profile";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}