re = /^(deb|deb-src)\s+(http:\/\/[^\s]*debian[^\s]*)\s+(.+?)\s+main\s+contrib.*$
/m
str = 'deb http://ftp.ru.debian.org/debian bullseye main contrib
deb-src http://ftp.ru.debian.org/debian bullseye main contrib
deb http://security.debian.org/debian-security bullseye-security main contrib
deb-src http://security.debian.org/debian-security bullseye-security main contrib
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end