# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\\")([^\\n]*)(\\n)([^\\n]*)(\\")/$2 $4/g;t' <<< "companyaddress2\r\nmultiple1,\\"my address row 1\nmy address row 2\\",12345,\\"my address 22222 row 1\nmy address 2222 row 2\\"\r\n"