using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\\"")([^\\n]*)(\\n)([^\\n]*)(\\"")";
string substitution = @"$2 $4";
string input = @"companyaddress2\r\nmultiple1,\""my address row 1\nmy address row 2\"",12345,\""my address 22222 row 1\nmy address 2222 row 2\""\r\n";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}