package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\\")([^\\n]*)(\\n)([^\\n]*)(\\")`)
var str = `companyaddress2\r\nmultiple1,\"my address row 1\nmy address row 2\",12345,\"my address 22222 row 1\nmy address 2222 row 2\"\r\n`
var substitution = "$2 $4"
fmt.Println(re.ReplaceAllString(str, substitution))
}