# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\\\")([^\\n]*)(\\n)([^\\n]*)(\\\")"
test_str = "companyaddress2\\r\\nmultiple1,\\\"my address row 1\\nmy address row 2\\\",12345,\\\"my address 22222 row 1\\nmy address 2222 row 2\\\"\\r\\n"
subst = "$2 $4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.