$re = '/(?<=.{2}).(?=[^@]*?@)/m';
$str = 'testaccount@gmail.com';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;