$re = '/^(
((?:22[0-3]|2([0-1])?\d?|([1-9][0-9]?|1[0-9]{2}))\.) # a group, 1-223 with "."
((?:25[0-5]|2[0-4]\d|[01]?(\d{0,2}))\.){2} # b and c groups 0-255 with "."
((25[0-5]|2[0-4]\d|[01]?(\d{0,2})) # d group, ends with optional netmask instead of "." // i tried making this non-optional as a group to solve my problem.
(\/([89]|[12]\d|3[0-2]))?) # netmask
,?\h?){1,50}$ # allow comma separated, optional space between, up to 50 IPs/mx';
$str = '1.1.1.
1.1.1.2
1.1.1.2/23
1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23,1.1.1.2/23';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);