// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(")(\S.*?\S)(")"#).unwrap();
let string = "\"el taller del traductor\"";
let substitution = "«$2»";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}