const regex = /\d+\s+-.*?(?=\s+-|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\s+-.*?(?=\\s+-|$)', 'gm')
const str = `"Option 01 - Random phrase - Top Menu
"Option 02 - Another Random Phrase - Su Menu
"Option 03 - More 01 Phrase - Menu
"Option 04 - More Phrase -
"Option 05 - Simple Phrase`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}