using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=CLD:\s).*";
string input = @"FF YBRFYMYX YMMCYMYX YSRFYMYX
061702 YBBNITAS
ATIS YBBN H 061702
RWY: 14
OPR INFO: RUNWAY 19 LEFT AVAILABLE AS PUR NOTAM. MULTIPLE
TAXIWAY CLOSURES REFER NOTAMS.
WND: 200/6
VIS: GREATER THAN 10 KM
CLD: FEW040
+ TMP: 13
+ QNH: 1016";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}