use strict;
my $str = 'FF YBRFYMYX YMMCYMYX YSRFYMYX
061702 YBBNITAS
ATIS YBBN H 061702
RWY: 14
OPR INFO: RUNWAY 19 LEFT AVAILABLE AS PUR NOTAM. MULTIPLE
TAXIWAY CLOSURES REFER NOTAMS.
WND: 200/6
VIS: GREATER THAN 10 KM
CLD: FEW040
+ TMP: 13
+ QNH: 1016';
my $regex = qr/(?<=CLD:\s).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}