Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(youtube|you_other_url_format).*?(?:[\/]|v=)([a-zA-Z0-9-_]{11})
/
gmi
Input 1
1
New
http://www.youtube.com/watch?v=jhjhkum-kq8&feature=related https://www.youtube.com/watch?list=RDfRh_vgS2dFE&v=fRh_vgS2dFE https://www.youtube.com/watch?v=fRh_vgS2dFE&list=RDfRh_vgS2dFE https://www.youtube.com/embed/NMKkz9uRXJc