#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)^\[(?P<type>.+)\]\:\ (?P<subject>(.+)\.)(?=[\r\n|\r|\n]*Description)"
Local $sString = "[FIX]: Fix bad wiring on plane 334, 335," & @CRLF & _
"and 336. Remove decorator for 478." & @CRLF & _
"" & @CRLF & _
"Description:" & @CRLF & _
"1. sadsadad." & @CRLF & _
"2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd." & @CRLF & _
"3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas," & @CRLF & _
"asdjasdaskdaskdhaslkjdlasjdkasd." & @CRLF & _
"" & @CRLF & _
"Reference: #232" & @CRLF & _
"" & @CRLF & _
"^\[(?P<type>.+)\]\:\ (?P<subject>(.|\r\n|\r|\n)+\.$)(?=[\r\n|\r|\n]*Description) => ~13ms (5k steps) /gm" & @CRLF & _
"" & @CRLF & _
"^\[(?P<type>.+)\]\:\ (?P<subject>(.*)\.)(?=[\r\n|\r|\n]*Description) => ~5ms (1-2k steps) /gs" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")