const regex = /^\[(?P<type>.+)\]\:\ (?P<subject>(.+)\.)(?=[\r\n|\r|\n]*Description)/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\[(?P<type>.+)\\]\\:\\ (?P<subject>(.+)\\.)(?=[\\r\\n|\\r|\\n]*Description)', 'gs')
const str = `[FIX]: Fix bad wiring on plane 334, 335,
and 336. Remove decorator for 478.
Description:
1. sadsadad.
2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.
3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas,
asdjasdaskdaskdhaslkjdlasjdkasd.
Reference: #232
^\\[(?P<type>.+)\\]\\:\\ (?P<subject>(.|\\r\\n|\\r|\\n)+\\.\$)(?=[\\r\\n|\\r|\\n]*Description) => ~13ms (5k steps) /gm
^\\[(?P<type>.+)\\]\\:\\ (?P<subject>(.*)\\.)(?=[\\r\\n|\\r|\\n]*Description) => ~5ms (1-2k steps) /gs
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}