import Foundation
let pattern = #"^\[(?P<type>.+)\]\:\ (?P<subject>(.+)\.)(?=[\r\n|\r|\n]*Description)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = ##"""
[FIX]: Fix bad wiring on plane 334, 335,
and 336. Remove decorator for 478.
Description:
1. sadsadad.
2. kjadhkahsdkahdjakdskashdkasjdsahdkhadhkasdhjkhaskd.
3. djasdasdasdadkajdsjaskldjalkdjalsjdlajsdlkjasdlas,
asdjasdaskdaskdhaslkjdlasjdkasd.
Reference: #232
^\[(?P<type>.+)\]\:\ (?P<subject>(.|\r\n|\r|\n)+\.$)(?=[\r\n|\r|\n]*Description) => ~13ms (5k steps) /gm
^\[(?P<type>.+)\]\:\ (?P<subject>(.*)\.)(?=[\r\n|\r|\n]*Description) => ~5ms (1-2k steps) /gs
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)