#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*((2020Model|Engine|TIMFCST).*\.dba|.*\.dta)"
Local $sString = "Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\2020db.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\ccaldb.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\cinput.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\cinput2.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\coutput.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\coutput2.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\ecaldb.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\egcaldb.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\eginput.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\egoutput.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\egoutput2.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\egoutput3.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\einput.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\eoutput.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\2020Model\ercaldb.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\Engine\erinput.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\testing.dta" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\Informetrica\informet.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.11 2020CanadaLinden\Informetrica\TIMFCST\F2201_EC\informet.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.13_2020ESDC\Informetrica\informet.dba" & @CRLF & _
"Deleted file - c:\Archives\23.01.13_2020ESDC\Informetrica\TIMFCST\F2201_EC\informet.dba"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")