import re
regex = re.compile(r"^.*((2020Model|Engine|TIMFCST).*\.dba|.*\.dta)", flags=re.MULTILINE)
test_str = ("Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\2020db.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\ccaldb.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\cinput.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\cinput2.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\coutput.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\coutput2.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\ecaldb.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egcaldb.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\eginput.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egoutput.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egoutput2.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\egoutput3.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\einput.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\eoutput.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\2020Model\\ercaldb.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\Engine\\erinput.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\testing.dta\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\Informetrica\\informet.dba\n"
"Deleted file - c:\\Archives\\23.01.11 2020CanadaLinden\\Informetrica\\TIMFCST\\F2201_EC\\informet.dba\n"
"Deleted file - c:\\Archives\\23.01.13_2020ESDC\\Informetrica\\informet.dba\n"
"Deleted file - c:\\Archives\\23.01.13_2020ESDC\\Informetrica\\TIMFCST\\F2201_EC\\informet.dba")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")