using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z][a-z\d]*(?:_[a-z\d]+)*$";
string input = @"_
A
abcd
a_2_c_3
aB_C
1abc
ab__c
a_b_
Humpty Dumpty
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}