import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z][a-z\\d]*(?:_[a-z\\d]+)*$";
final String string = "_\n"
+ "A\n"
+ "abcd\n"
+ "a_2_c_3\n"
+ "aB_C\n"
+ "1abc\n"
+ "ab__c\n"
+ "a_b_\n"
+ "Humpty Dumpty\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}