re = /^[a-z][a-z\d]*(?:_[a-z\d]+)*$/mi
str = '_
A
abcd
a_2_c_3
aB_C
1abc
ab__c
a_b_
Humpty Dumpty
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end