// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[a-z][a-z\d]*(?:_[a-z\d]+)*$").unwrap();
let string = "_
A
abcd
a_2_c_3
aB_C
1abc
ab__c
a_b_
Humpty Dumpty
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}