using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(\s*.*?\w*\h*,(*SKIP)(*F)|(?|("")[^""\\]*(?:\\.[^""\\]*)*""|(')[^'\\]*(?:\\.[^'\\]*)*')";
string input = @"a=""abc"";
b='def';
c=""That's the way to do it"";
d='That\'s the way ""to do it""';
e=e.replace(//g, '""');
f=f.replace(/'/g, '""');
g=g.replace(/\'/g, '""');
h=h.replace(/\""/g, '\""');
i=i.replace(/\\""/g, '\\""');";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}