import Foundation
let pattern = #"^(WSPRD2\b.*\r?\n(?:(?!END\b).*\r?\n)*).*\bDELESTAT\b.*\r?\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
WSPRD3#/TO/PATH/TASK5
PRIORITY 60
NEEDS 1 MASTER#AAA0RTYU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAA1JK
FOLLOWS GET_INPUT
END
WSPRD2#/TO/PATH/TASK6
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
FOLLOWS GET_INPUT
END
WSPRD4#/TO/PATH/TASK8
PRIORITY 60
NEEDS 1 MASTER#AAA0RETU
NEEDS 1 MASTER#DELESTAT
NEEDS 1 MASTER#RAAACCC
FOLLOWS GET_INPUT
END
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)