using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:[^a-zA-Z\n]*[a-zA-Z]){2}).{8,}$";
string input = @"helloworl
HelloWorld-1
Y1232456";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}