re = /^(?=(?:[^a-zA-Z\n]*[a-zA-Z]){2}).{8,}$/m
str = 'helloworl
HelloWorld-1
Y1232456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end