package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\s\.\,]|^)[^#]\w+([\s\.\,]*?|$)`)
var str = `This is a #text, which is #full of #hashtags.
Well, this is not #easy to
#extract #them.
I think I #start to lose: #hope.`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}