# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[-.\w]+@(?![^.]{0,2}\.[a-zA-Z]{2,}$)([-a-zA-Z0-9]+\.)+[a-zA-Z]{2,}$"
test_str = ("// Matching\n"
"abc@gmx.dcom\n"
"newemail@gmail.com\n"
"8-d_873@abc.co\n"
"abc.deg@new.co\n"
"abc@9mail.co\n"
"d@mail.com\n"
"abc.deg@new.co.uk\n\n"
"// Not matching\n"
"abc@gmc.d\n"
"abc@gm.de\n"
"d@ma.com\n"
"d@\n"
"9@99.213\n"
"first.name@gmx...de")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.