$re = '/(?:^|[\r\n]+)jenkins:([, a-zA-Z_]+)(?:$|[\r\n]+)/';
$str = 'jenkins:BASE_TEST, RADIO_TEST
blablablabla';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);