using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/dev\/disk0s2).* (\d*\.\d+)?Ti";
string input = @"/dev/disk0s2 3.6Ti 2.9Ti 796Gi 79% 383906083 104366287 79% /
/dev/disk0s3 1.2Ti 1.3Ti 796Gi 79% 383906083 104366287 79% /
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}