package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\/dev\/disk0s2).* (\d*\.\d+)?Ti`)
var str = `/dev/disk0s2 3.6Ti 2.9Ti 796Gi 79% 383906083 104366287 79% /
/dev/disk0s3 1.2Ti 1.3Ti 796Gi 79% 383906083 104366287 79% /
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}