re = /\B(room)\B|\b(room)\b|(room)/im
str = 'Meeting.Room
MeetingRoom21
Room
Meeting2Room
Meeting.room
12MeetingRoom110.MeetingRoom'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end