# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\w+\s*\n|([\w ]+)\n*(\1\n+)*/\2/gm;t' <<< "we
all
have
a
unique
perspective
on
the
we all have a unique perspective on the
we all have a unique perspective on the
world
around
us
and
believe
it
or
not
world around us and believe it or not
world around us and believe it or not
"