import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\s*\\n|([\\w ]+)\\n*(\\1\\n+)*";
final String string = "we\n"
+ "all\n"
+ "have\n"
+ "a\n"
+ "unique\n"
+ "perspective\n"
+ "on\n"
+ "the\n"
+ "we all have a unique perspective on the\n\n"
+ "we all have a unique perspective on the\n"
+ "world\n"
+ "around\n"
+ "us\n"
+ "and\n"
+ "believe\n"
+ "it\n"
+ "or\n"
+ "not\n"
+ "world around us and believe it or not\n\n"
+ "world around us and believe it or not\n";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}