$re = '@(.*?href=")(https?://[^"]*)@m';
$str = 'Can support \\r \\n to the newline format.
<div yne-ht: 1.75; foize: 14px;"><a href="https://chrome.google.com/webstore"><span style="font-sit-family:57);"> </span><a href="https://microsoftedge.microsoft.com/addons"><span style>微软商店</span></a><span st 57, 57);"> </span><a href="https://crx4chrome.com" n style="font ><span style="font
!(.*?href=")(https?://[^"]*)!$2\\r!gm
!(.*?href=")(https?://[^"]*)!$2\\n!gm
';
$subst = "$2\r";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;