// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(|by DocuSign)((|0)[1-9]|1[0-2])\/((|0)[1-9]|[1-2][0-9]|3[0-1])\/[0-9]{4}$").unwrap();
let string = "01/31/2021
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}