import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(M.{2,}?)<STOP>";
final String string = "res = [\n"
+ " 'NVAKMFPQRKFT<STOP>TVQTLMRNGTLLERG<STOP>CCEVSP',\n\n"
+ " 'QKRMDCNASV<STOP>TVTVQTLMQTL<STOP>TNTPKGG<STOP>',\n\n"
+ " 'MEKGYADAE<STOP>RKTF<STOP>MTVRAGCCGI<STOP>MK'\n"
+ "]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}