re = /^(?=.*[A-Za-z])(?=.*\d)[A-Za-z0-9\-#.\/]+$/m
str = 'abc
123
abc123
abc123#
abc#
123#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end