package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)^[\w\s.-]+$`)
var str = `some string
not&
eh um.
some----`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}