# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=(?:(?:\\x1b\[[0-9;]+m)?.){80})(?:(?:\\x1b\[[0-9;]+m)?.){0,80}\K /\n/ug;t' <<< "Morbi leo risus, \x1b[34;1mporta ac consectetur\x1b[39;22m ac, vestibulum at eros. Aenean lacinia bibendum nulla sed consectetur. Nullam id dolor id nibh ultricies vehicula ut id elit. Aenean lacinia bibendum nulla sed consectetur. Curabitur blandit tempus porttitor."