$re = '/^[\p{L}\'-][\p{L}\' -]{1,25}$/';
$str = 'bcdasdfsd sdfsA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);