$re = '/([.!?]) *([A-Z])/m';
$str = 'TheEuropean languages are members of the same family
.Their separate existence isamyth. For science,music,
sport,etc,Europeusesthe same vocabulary.Thelanguages only d
iffer in their grammar,their pronunciation andtheirmostcommon
words.Everyonerealizeswhyanewcommonlanguagewouldbedesirable:onecould
refusetopayexpensivetranslators.';
$subst = " $1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;