import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[(A-H|J-N|P|R-Z|0-9)]{17}\\b";
final String string = "The VIN number on a vehicle is a 17 alpha-numeric characters and must NOT contain the letters I, O or Q (to avoid confusion with the similar looking digits). \n"
+ "So, for example, SALVA2AE4EH877322 is valid, but SALVO2AE4EH877322 is not.\n"
+ "By using the \\b word boundary token, we can match in quotes \"SALVA2AE4EH877482\", brackets (SALVA2AE4EH877998) or other boundaries that people may use <SALVA2AE4EH877002>\n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}