Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
"
(pty|ltd|trust|incorporated|npc|association|npo|corporation|limited|foundation|soe)|(close).*(corp)|(corp).*(close)|[\W\s\d]+(cc|inc)[\W\s\d]+|[\w\D]+(cc|inc)[^a-zA-Z\s]+|[^a-zA-Z\s]+(cc|inc)[\w\D]+|^(cc|inc)[\W\s\d]+|[\W\s\d]+(cc|inc)$|^(cc|inc)$
"
mig
Input 1
1
New
"Sen Do INC","Sen Do INC",