#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!^)|\bhref="(?=[^"]*\.(?:html?|php)"))[^"<_]*\K_"
Local $sString = "href="http://some.site.com/path_here_and_here/site.html"" & @CRLF & _
"href="http://some.site.com/path_here_and_here/site.htm"" & @CRLF & _
"href="http://some.site.com/path_here_and_here/site.php"" & @CRLF & _
"" & @CRLF & _
"href="http://some.site.com/path_here_and_here/site.exe"" & @CRLF & _
"href="http://some.site.com/path_here_and_here/site.zip"" & @CRLF & _
"href="http://some.site.com/path_here_and_here/site.sit"" & @CRLF & _
"href="http://some.site.com/path_here_and_here/site.dmg""
Local $sSubst = "-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)