use strict;
my $str = 'href="http://some.site.com/path_here_and_here/site.html"
href="http://some.site.com/path_here_and_here/site.htm"
href="http://some.site.com/path_here_and_here/site.php"
href="http://some.site.com/path_here_and_here/site.exe"
href="http://some.site.com/path_here_and_here/site.zip"
href="http://some.site.com/path_here_and_here/site.sit"
href="http://some.site.com/path_here_and_here/site.dmg"';
my $regex = qr/(?:\G(?!^)|\bhref="(?=[^"]*\.(?:html?|php)"))[^"<_]*\K_/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";