package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\S+) - - \[(\S+).*\] \"GET (.*?/)\s+`)
var str = `xx.xx.xx.xx - - [12/Jul/2018:19:29:43 +0800] "GET /2018/07/06/antique-internet/ HTTP/1.1" 200 5489 "https://miscnote.net/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36"
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}