#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ix)^(|(?:.|\n)+\n)From:[\s\t]*((?:.|\n)*?)(|\n\S(?:.|\n)*)$"
Local $sString = "from: grtrtr" & @CRLF & _
" ghhjjyjkyrur6uy yu6yu"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")