import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(|(?:.|\\n)+\\n)From:[\\s\\t]*((?:.|\\n)*?)(|\\n\\S(?:.|\\n)*)$";
final String string = "from: grtrtr\n"
+ " ghhjjyjkyrur6uy yu6yu";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}