import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$";
final String string = "feat: NSPS2-1277 A valid commit message\n"
+ "chore:NSPS2-1277 A valid commit message\n"
+ "fix: NSPS2-1277 A valid commit message\n"
+ "security: NSPS2-1277 A valid commit message\n"
+ "wip: NSPS2-1277 A valid commit message";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}